package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w{3}-\w{3,4}-\d{3})`)
var str = `tl_FZP-FDD2-145_FZP-FDD2-147`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}