$re = '/(\w{3}-\w{3,4}-\d{3})/';
$str = 'tl_FZP-FDD2-145_FZP-FDD2-147';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);