re = /<(|\/)(?!\?).*?(|\/)>/
str = '<span style="font-size: 8pt;" >Спасибо за заказ! Номер Вашего заказа <?= $order->id ?> Ваш Заочник.бай
</span>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end