import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<date>((19|20)\\d{2})[-/.]([1-9]|1[012])[-/.]([1-9]|[12][0-9]|3[01]))";
final String string = "this is due on 2021-9-2 at 10:00 am\n"
+ "this is due on 2021/9/2 at 10:00 am\n"
+ "this is due on 2021.9.2 at 10:00 am";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}