const regex = new RegExp('(?P<date>((19|20)\\d{2})[-/.]([1-9]|1[012])[-/.]([1-9]|[12][0-9]|3[01]))', 'gm')
const str = `this is due on 2021-9-2 at 10:00 am
this is due on 2021/9/2 at 10:00 am
this is due on 2021.9.2 at 10:00 am`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}