const regex = /(?<=[A-Z]{2}-\d{4}-\d{2} to )-??\d{2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Z]{2}-\\d{4}-\\d{2} to )-??\\d{2}', 'gm')
const str = `AR-0000-00 to -88
AR-0000-00 to 88
AR-0000-21 to -88
GB-1234-90 to -00
GB-2222-00 to 20
GB-2222-00 to
B-22-00 to 20
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}