use strict;
my $str = 'AR-0000-00 to -88
AR-0000-00 to 88
AR-0000-21 to -88
GB-1234-90 to -00
GB-2222-00 to 20
GB-2222-00 to
B-22-00 to 20
';
my $regex = qr/(?<=[A-Z]{2}-\d{4}-\d{2} to )-??\d{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}