$re = '/(.*\/wiki.*\/).*/';
$str = 'http://88.181.108.14:777/wiki/aaa';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);