$re = '~\{[\S\s]*?(,\s+"[^"]*")\s+\}~';
$str = '{
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);