re = /\{[\S\s]*?(,\s+"[^"]*")\s+\}/
str = '{
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
{ SomeTextNoQuotes, "Some Text\'s", "Some Text" },
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end