package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(^|\s)((https?:\/\/)?[\w-]+(\.[a-z-]+)+\.?(:\d+)?(\/\S*)?)`)
var str = `bit.ly/00a0sa0sasaxsdd
http://bit.ly/00a0sa0sasaxsdd
https://bit.ly/00a0sa0sasaxsdd
http://www.terra.es/asasa
https://www.terra.es/asasa
https://www.terra.es.com/asasas
https://www.terra2.es.com/asasas
3.0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}