#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[.*?]"
Local $sString = "." & @CRLF & _
"g" & @CRLF & _
"*" & @CRLF & _
"fisudfios" & @CRLF & _
"[sfsdfsdfsf]" & @CRLF & _
"[?]" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)