import re
regex = re.compile(r"^(?:0|(?:\+|00) ?31 ?)(?:(?:[1-9] ?(?:[0-9] ?){8})|(?:6 ?-? ?[1-9] ?(?:[0-9] ?){7})|(?:[1,2,3,4,5,7,8,9]\d ?-? ?[1-9] ?(?:[0-9] ?){6})|(?:[1,2,3,4,5,7,8,9]\d{2} ?-? ?[1-9] ?(?:[0-9] ?){5}))$", flags=re.MULTILINE)
test_str = ("this is a list of numbers inline 06-12345678 gggf0612345678 06 12345678 0101234567 010-1234567 dfgfdg010 1234567 010 12 34 567 more 010 12 34567 yes 010 1234 567 and more +31612345678 and more and this 0031123456789\n"
"dfgfd and here are some separate lines:\n"
"06-12345678\n"
"0612345678\n"
"0612345678\n"
"0101234567\n"
"010-1234567\n"
"010 1234567\n"
"010 12 34 567\n"
"010 12 34567\n"
"010 1234 567\n"
"+31612345678\n"
"0031123456789\n"
"ghf@fghgfh.coml\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")