$re = '/[a-z][primerapellido][a-z](1|\0)(1-9|\0)(0|\0)([0-1]|\0])[@]([alumno]|\0)(.|\0)[ipn][.][mx]$/m';
$str = 'aprimerapellidoa1100@alumno.ipn.mx$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);