re = /[a-z][primerapellido][a-z](1|\0)(1-9|\0)(0|\0)([0-1]|\0])[@]([alumno]|\0)(.|\0)[ipn][.][mx]$/m
str = 'aprimerapellidoa1100@alumno.ipn.mx$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end