const regex = /((http|https):(\/\/)|www\.)\w*\.*\-*[^(mysite.com)(theothermysite.net)]\w*\.?[^\s\t\r\n\"]*/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((http|https):(\\\/\\\/)|www\\.)\\w*\\.*\\-*[^(mysite.com)(theothermysite.net)]\\w*\\.?[^\\s\\t\\r\\n\\"]*', 'igm')
const str = `www.demo.com
// End -->
http://www.foo.co.uk/
http://regexr.com/foo.html?q=bar
"https://mediatemple.net"
HTTP://mediatemple.net
<SOURCE src="https://12-lvdl.vimeo.com/01/1087/5/130436788/397857524.mp4?expires=1449922638&token=07929326b8cd27cd962f3" type="video/mp4">
href="http://www.testsite.net/dashboard/editor/uploads/image_uploads/2012/12/12/p6fdVfdfQv0CEhfTf8FHd3A7sNmXigy1K.jpg" width="100%">
href="http://mysite.com/mailer/themes/Theme1/img/IMG_0001"
href="http://theothermysite.net/mailer/themes/Theme1/img/IMG_0001"
www.theothermysite.net/mailer/themes/Theme1/img/IMG_0001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}