use strict;
my $str = 'www.demo.com
// End -->
http://www.foo.co.uk/
http://regexr.com/foo.html?q=bar
"https://mediatemple.net"
HTTP://mediatemple.net
<SOURCE src="https://12-lvdl.vimeo.com/01/1087/5/130436788/397857524.mp4?expires=1449922638&token=07929326b8cd27cd962f3" type="video/mp4">
href="http://www.testsite.net/dashboard/editor/uploads/image_uploads/2012/12/12/p6fdVfdfQv0CEhfTf8FHd3A7sNmXigy1K.jpg" width="100%">
href="http://mysite.com/mailer/themes/Theme1/img/IMG_0001"
href="http://theothermysite.net/mailer/themes/Theme1/img/IMG_0001"
www.theothermysite.net/mailer/themes/Theme1/img/IMG_0001';
my $regex = qr/((http|https):(\/\/)|www\.)\w*\.*\-*[^(mysite.com)(theothermysite.net)]\w*\.?[^\s\t\r\n\"]*/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}