using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"R\$\s^\d{1,3}(?:\.\d{3})*,\d{2}";
string input = @"R$ 110,00";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}