const regex = /(?<!\bor|\band)\s(?!or\b|and\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\bor|\\band)\\s(?!or\\b|and\\b)', 'g')
const str = `ield = 10 and field2= 100 or field10 is not null
horror andy hodor band land of`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}