$re = '/(?<!\bor|\band)\s(?!or\b|and\b)/';
$str = 'ield = 10 and field2= 100 or field10 is not null
horror andy hodor band land of';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);