package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^\]\[]*\]:\s*(.*?)\[\w*:`)
var str = `00:0qwe8.0 donald controller duck [02009&123@##]: Some more sring here Model number 420 Family [Super-cool] [15b31013^^@#][15b:31013]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}