re = /\[[^\]\[]*\]:\s*(.*?)\[\w*:/m
str = '00:0qwe8.0 donald controller duck [02009&123@##]: Some more sring here Model number 420 Family [Super-cool] [15b31013^^@#][15b:31013]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end