package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+,\s*\w+\s*\([^()]*(?:\([^()]*\)[^()]*)*\);?`)
var str = `Smith, Anna (Univ Cambridge); Doe, Jane (Univ Vienna (Austria)); Doe, John (Univ Tokyo; MIT)
Mueller, Hans (FU Berlin (Germany)); Schmid, Julia (); Doe, John (CalTech); Boe, Jane (TU Wien)
Kim, Lee (Nazarbayev Univ (Kazakhstan); Univ Oxford)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}