re = /\w+,\s*\w+\s*\([^()]*(?:\([^()]*\)[^()]*)*\);?/m
str = 'Smith, Anna (Univ Cambridge); Doe, Jane (Univ Vienna (Austria)); Doe, John (Univ Tokyo; MIT)
Mueller, Hans (FU Berlin (Germany)); Schmid, Julia (); Doe, John (CalTech); Boe, Jane (TU Wien)
Kim, Lee (Nazarbayev Univ (Kazakhstan); Univ Oxford)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end