using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*Woznica wola:.+\.$";
string input = @"Woznica wola: Test.
Woznica wola: Test, kurde.
Woznica wola: Test!
Woznica wola: Test, kurde!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}