package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*\.js\?ver=[\.0-9]+)$`)
var str = `ddghdghdghdgh.js?ver=0.1.3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}