$re = '/^(.*\.js\?ver=[\.0-9]+)$/';
$str = 'ddghdghdghdgh.js?ver=0.1.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);