package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:, que o estudante ([\s\w]*) completou)`)
var str = `os devidos fins, que o estudante Carolaíne Denega completou`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}