$re = '/(?:, que o estudante ([\s\w]*) completou)/mi';
$str = 'os devidos fins, que o estudante Carolaíne Denega completou';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);