package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d,]+`)
var str = `980,232 905,903 889,614 881,145 2,343,435 3,435,123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}