$re = '/[\d,]+/';
$str = '980,232 905,903 889,614 881,145 2,343,435 3,435,123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);