#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(Device\s#\d(\n.*)*?(?=\n\s*Device\s#|\Z))"
Local $sString = " Controllers found: 1" & @CRLF & _
"----------------------------------------------------------------------" & @CRLF & _
"Physical Device information" & @CRLF & _
"----------------------------------------------------------------------" & @CRLF & _
" Device #0" & @CRLF & _
" Device is a Hard drive" & @CRLF & _
" State : Online" & @CRLF & _
" Supported : Yes" & @CRLF & _
" Transfer Speed : SAS 3.0 Gb/s" & @CRLF & _
" Reported Channel,Device(T:L) : 0,0(0:0)" & @CRLF & _
" Reported Location : Enclosure 0, Slot 31" & @CRLF & _
" Reported ESD(T:L) : 2,0(0:0)" & @CRLF & _
" Vendor : HP" & @CRLF & _
" Model : DG072A4951" & @CRLF & _
" Firmware : HPDB" & @CRLF & _
" Serial number : P2VDJTUA" & @CRLF & _
" World-wide name : 5000CCA00016CE17" & @CRLF & _
" Reserved Size : 109705 KB" & @CRLF & _
" Used Size : 69900 MB" & @CRLF & _
" Unused Size : 64 KB" & @CRLF & _
" Total Size : 70007 MB" & @CRLF & _
" Write Cache : Enabled (write-back)" & @CRLF & _
" FRU : None" & @CRLF & _
" S.M.A.R.T. : No" & @CRLF & _
" S.M.A.R.T. warnings : 0" & @CRLF & _
" Power State : Full rpm" & @CRLF & _
" Supported Power States : Full rpm,Powered off" & @CRLF & _
" SSD : No" & @CRLF & _
" Device #1" & @CRLF & _
" Device is a Hard drive" & @CRLF & _
" State : Online" & @CRLF & _
" Supported : Yes" & @CRLF & _
" Transfer Speed : SAS 3.0 Gb/s" & @CRLF & _
" Reported Channel,Device(T:L) : 0,1(1:0)" & @CRLF & _
" Reported Location : Enclosure 0, Slot 30" & @CRLF & _
" Reported ESD(T:L) : 2,0(0:0)" & @CRLF & _
" Vendor : HP" & @CRLF & _
" Model : DG072A4951" & @CRLF & _
" Firmware : HPDB" & @CRLF & _
" Serial number : P2VDLG6A" & @CRLF & _
" World-wide name : 5000CCA00016E6FB" & @CRLF & _
" Reserved Size : 109705 KB" & @CRLF & _
" Used Size : 69900 MB" & @CRLF & _
" Unused Size : 64 KB" & @CRLF & _
" Total Size : 70007 MB" & @CRLF & _
" Write Cache : Enabled (write-back)" & @CRLF & _
" FRU : None" & @CRLF & _
" S.M.A.R.T. : No" & @CRLF & _
" S.M.A.R.T. warnings : 0" & @CRLF & _
" Power State : Full rpm" & @CRLF & _
" Supported Power States : Full rpm,Powered off" & @CRLF & _
" SSD : No" & @CRLF & _
" Device #2" & @CRLF & _
" Device is a Hard drive" & @CRLF & _
" State : Online" & @CRLF & _
" Supported : Yes" & @CRLF & _
" Transfer Speed : SAS 6.0 Gb/s" & @CRLF & _
" Reported Channel,Device(T:L) : 0,2(2:0)" & @CRLF & _
" Reported Location : Enclosure 0, Slot 29" & @CRLF & _
" Reported ESD(T:L) : 2,0(0:0)" & @CRLF & _
" Vendor : HP" & @CRLF & _
" Model : EG0300FAWHV" & @CRLF & _
" Firmware : HPDE" & @CRLF & _
" Serial number : 6SE4RLA90000B206N27S" & @CRLF & _
" World-wide name : 5000C500429DA878" & @CRLF & _
" Reserved Size : 415982 KB" & @CRLF & _
" Used Size : 285696 MB" & @CRLF & _
" Unused Size : 64 KB" & @CRLF & _
" Total Size : 286102 MB" & @CRLF & _
" Write Cache : Enabled (write-back)" & @CRLF & _
" FRU : None" & @CRLF & _
" S.M.A.R.T. : No" & @CRLF & _
" S.M.A.R.T. warnings : 0" & @CRLF & _
" Power State : Full rpm" & @CRLF & _
" Supported Power States : Full rpm,Powered off" & @CRLF & _
" SSD : No" & @CRLF & _
" Device #3" & @CRLF & _
" Device is a Hard drive" & @CRLF & _
" State : Online" & @CRLF & _
" Supported : Yes" & @CRLF & _
" Transfer Speed : SAS 6.0 Gb/s" & @CRLF & _
" Reported Channel,Device(T:L) : 0,3(3:0)" & @CRLF & _
" Reported Location : Enclosure 0, Slot 28" & @CRLF & _
" Reported ESD(T:L) : 2,0(0:0)" & @CRLF & _
" Vendor : HP" & @CRLF & _
" Model : EG0300FAWHV" & @CRLF & _
" Firmware : HPDE" & @CRLF & _
" Serial number : 6SE4NYMY0000B20416MP" & @CRLF & _
" World-wide name : 5000C50042999500" & @CRLF & _
" Reserved Size : 415982 KB" & @CRLF & _
" Used Size : 285696 MB" & @CRLF & _
" Unused Size : 64 KB" & @CRLF & _
" Total Size : 286102 MB" & @CRLF & _
" Write Cache : Enabled (write-back)" & @CRLF & _
" FRU : None" & @CRLF & _
" S.M.A.R.T. : No" & @CRLF & _
" S.M.A.R.T. warnings : 0" & @CRLF & _
" Power State : Full rpm" & @CRLF & _
" Supported Power States : Full rpm,Powered off" & @CRLF & _
" SSD : No"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")