const regex = /(Device\s#\d(\n.*)*?(?=\n\s*Device\s#|\Z))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Device\\s#\\d(\\n.*)*?(?=\\n\\s*Device\\s#|\\Z))', 'g')
const str = ` Controllers found: 1
----------------------------------------------------------------------
Physical Device information
----------------------------------------------------------------------
Device #0
Device is a Hard drive
State : Online
Supported : Yes
Transfer Speed : SAS 3.0 Gb/s
Reported Channel,Device(T:L) : 0,0(0:0)
Reported Location : Enclosure 0, Slot 31
Reported ESD(T:L) : 2,0(0:0)
Vendor : HP
Model : DG072A4951
Firmware : HPDB
Serial number : P2VDJTUA
World-wide name : 5000CCA00016CE17
Reserved Size : 109705 KB
Used Size : 69900 MB
Unused Size : 64 KB
Total Size : 70007 MB
Write Cache : Enabled (write-back)
FRU : None
S.M.A.R.T. : No
S.M.A.R.T. warnings : 0
Power State : Full rpm
Supported Power States : Full rpm,Powered off
SSD : No
Device #1
Device is a Hard drive
State : Online
Supported : Yes
Transfer Speed : SAS 3.0 Gb/s
Reported Channel,Device(T:L) : 0,1(1:0)
Reported Location : Enclosure 0, Slot 30
Reported ESD(T:L) : 2,0(0:0)
Vendor : HP
Model : DG072A4951
Firmware : HPDB
Serial number : P2VDLG6A
World-wide name : 5000CCA00016E6FB
Reserved Size : 109705 KB
Used Size : 69900 MB
Unused Size : 64 KB
Total Size : 70007 MB
Write Cache : Enabled (write-back)
FRU : None
S.M.A.R.T. : No
S.M.A.R.T. warnings : 0
Power State : Full rpm
Supported Power States : Full rpm,Powered off
SSD : No
Device #2
Device is a Hard drive
State : Online
Supported : Yes
Transfer Speed : SAS 6.0 Gb/s
Reported Channel,Device(T:L) : 0,2(2:0)
Reported Location : Enclosure 0, Slot 29
Reported ESD(T:L) : 2,0(0:0)
Vendor : HP
Model : EG0300FAWHV
Firmware : HPDE
Serial number : 6SE4RLA90000B206N27S
World-wide name : 5000C500429DA878
Reserved Size : 415982 KB
Used Size : 285696 MB
Unused Size : 64 KB
Total Size : 286102 MB
Write Cache : Enabled (write-back)
FRU : None
S.M.A.R.T. : No
S.M.A.R.T. warnings : 0
Power State : Full rpm
Supported Power States : Full rpm,Powered off
SSD : No
Device #3
Device is a Hard drive
State : Online
Supported : Yes
Transfer Speed : SAS 6.0 Gb/s
Reported Channel,Device(T:L) : 0,3(3:0)
Reported Location : Enclosure 0, Slot 28
Reported ESD(T:L) : 2,0(0:0)
Vendor : HP
Model : EG0300FAWHV
Firmware : HPDE
Serial number : 6SE4NYMY0000B20416MP
World-wide name : 5000C50042999500
Reserved Size : 415982 KB
Used Size : 285696 MB
Unused Size : 64 KB
Total Size : 286102 MB
Write Cache : Enabled (write-back)
FRU : None
S.M.A.R.T. : No
S.M.A.R.T. warnings : 0
Power State : Full rpm
Supported Power States : Full rpm,Powered off
SSD : No`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}