# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)<table(?:.*?(?R).*?|.*?)<\\/table>(*SKIP)(*F)|style=(['"])[^'"]*\1//g;t' <<< "<!-- more html here -->
<span style='do:smtg'><table class=... > <span style=\"...\">
<table> <div style=\"\"></div></table></span></table>
<!-- more html here -->
<table> <div style=\"\"></div></table>"