$re = '/(?s)<table(?:.*?(?R).*?|.*?)<\/table>(*SKIP)(*F)|style=([\'"])[^\'"]*\1/';
$str = '<!-- more html here -->
<span style=\'do:smtg\'><table class=... > <span style="...">
<table> <div style=""></div></table></span></table>
<!-- more html here -->
<table> <div style=""></div></table>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;