re = /.*"(:?GET|POST|HEAD) .* 403 [0-9]{3}.*/
str = 'domain.com:80 146.185.150.198 - - [16/Jun/2014:21:29:09 +0200] "GET /administrator/index.php HTTP/1.0" 403 358 "-" "-"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end