// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#".*"(:?GET|POST|HEAD) .* 403 [0-9]{3}.*"#).unwrap();
let string = "domain.com:80 146.185.150.198 - - [16/Jun/2014:21:29:09 +0200] \"GET /administrator/index.php HTTP/1.0\" 403 358 \"-\" \"-\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}