$re = '/(?!\S+…)(?:https?:)?\/\/\S+/';
$str = 'longtexthere https://fancy.link/ I get "longtexthere https://fa…';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);