re = /(?!\S+…)(?:https?:)?\/\/\S+/
str = 'longtexthere https://fancy.link/ I get "longtexthere https://fa…'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end