#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*/\K.{0,2}"
Local $sString = "/u01/app/oracle/dirprm/fm00lsk" & @CRLF & _
"/foo/x/ab00cmf" & @CRLF & _
"/foo/bar/x" & @CRLF & _
"/foo/somthing/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")