re = /.*\/\K.{0,2}/
str = '/u01/app/oracle/dirprm/fm00lsk
/foo/x/ab00cmf
/foo/bar/x
/foo/somthing/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end