package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'ABCD':('[^`]*')`)
var str = `'ABCD':'2321323123dfasdf908'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}