$re = '/\'ABCD\':(\'[^`]*\')/';
$str = '\'ABCD\':\'2321323123dfasdf908\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);