package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`field\[(\d*)\]\[(\d*)\]((?:\[")(.+)(?:"\]))?`)
var str = `field[123][33]["code"]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}