$re = '/field\[(\d*)\]\[(\d*)\]((?:\[")(.+)(?:"\]))?/';
$str = 'field[123][33]["code"]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);