package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-z0-9-_]+(.[A-Za-z0-9-_]+)*@[A-Za-z0-9-]+(.[A-Za-z0-9]+)*(.[A-Za-z]{2,})
`)
var str = `you.him@home.se
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}