re = /[A-Za-z0-9-_]+(.[A-Za-z0-9-_]+)*@[A-Za-z0-9-]+(.[A-Za-z0-9]+)*(.[A-Za-z]{2,})
/
str = 'you.him@home.se
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end