using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"balnearios";
string input = @"https://www.aesfas.org/balnearios/
https://www.aesfas.org/balnearios/asdfasdf
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}