#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?:" & @CRLF & _
" "[^"\r\n]*" |" & @CRLF & _
" '[^'\r\n]*' |" & @CRLF & _
" [^;]" & @CRLF & _
")*" & @CRLF & _
"(;\N+)?"
Local $sString = "#include <MsgBoxConstants.au3>" & @CRLF & _
"" & @CRLF & _
"If ProcessExists("SciTE.exe") = 0 Then" & @CRLF & _
" MsgBox($MB_SYSTEMMODAL, "", "You will need SciTE.exe to be running for ConsoleWrite to display.")" & @CRLF & _
"EndIf" & @CRLF & _
"" & @CRLF & _
"Example()" & @CRLF & _
"" & @CRLF & _
"Func Example()" & @CRLF & _
" ; Register the function MyAdLibFunc() to be called every 250ms (default)." & @CRLF & _
" AdlibRegister("MyAdLibFunc")" & @CRLF & _
"" & @CRLF & _
" ; Sleep does not stop AdLib functions from running." & @CRLF & _
" Sleep(1000)" & @CRLF & _
"" & @CRLF & _
" ; AdLib functions don't run while a blocking function is shown e.g. MsgBox, InputBox, WinWait, WinWaitClose etc." & @CRLF & _
" MsgBox($MB_SYSTEMMODAL, "", "No console message(s) will be shown whilst the messagebox is displayed.")" & @CRLF & _
"" & @CRLF & _
" ; The AdLib function MyAdLibFunc() will start again." & @CRLF & _
" Sleep(2000)" & @CRLF & _
"" & @CRLF & _
" ; Unregister the function MyAdLibFunc() from being called every 250ms." & @CRLF & _
" AdlibUnRegister("MyAdLibFunc")" & @CRLF & _
"EndFunc ;==>Example" & @CRLF & _
"" & @CRLF & _
"Func MyAdLibFunc()" & @CRLF & _
" ; Assign a static variable to hold the number of times the function is called." & @CRLF & _
" Local Static $iCount = 0" & @CRLF & _
" $iCount += 1" & @CRLF & _
"" & @CRLF & _
" ConsoleWrite("MyAdLibFunc called " & $iCount & " time(s)" & @CRLF)" & @CRLF & _
"EndFunc ;==>MyAdLibFunc" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")