# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:
"[^"\r\n]*" |
'[^'\r\n]*' |
[^;]
)*
(;\N+)?
"""
test_str = ("#include <MsgBoxConstants.au3>\n\n"
"If ProcessExists(\"SciTE.exe\") = 0 Then\n"
" MsgBox($MB_SYSTEMMODAL, \"\", \"You will need SciTE.exe to be running for ConsoleWrite to display.\")\n"
"EndIf\n\n"
"Example()\n\n"
"Func Example()\n"
" ; Register the function MyAdLibFunc() to be called every 250ms (default).\n"
" AdlibRegister(\"MyAdLibFunc\")\n\n"
" ; Sleep does not stop AdLib functions from running.\n"
" Sleep(1000)\n\n"
" ; AdLib functions don't run while a blocking function is shown e.g. MsgBox, InputBox, WinWait, WinWaitClose etc.\n"
" MsgBox($MB_SYSTEMMODAL, \"\", \"No console message(s) will be shown whilst the messagebox is displayed.\")\n\n"
" ; The AdLib function MyAdLibFunc() will start again.\n"
" Sleep(2000)\n\n"
" ; Unregister the function MyAdLibFunc() from being called every 250ms.\n"
" AdlibUnRegister(\"MyAdLibFunc\")\n"
"EndFunc ;==>Example\n\n"
"Func MyAdLibFunc()\n"
" ; Assign a static variable to hold the number of times the function is called.\n"
" Local Static $iCount = 0\n"
" $iCount += 1\n\n"
" ConsoleWrite(\"MyAdLibFunc called \" & $iCount & \" time(s)\" & @CRLF)\n"
"EndFunc ;==>MyAdLibFunc\n")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.